Dec 222009
 

I just upgraded the blog to the newest WordPress version 2.9 and it seems to be working fine. But plugins are the biggest headache while upgrading versions and that was the reason I jumped directly from 2.8.4 to 2.9 skipping the intermediates.

So, please let me know if you notice any funny behavior around here.

P.S: Here is the link to the upgrade instructions to 2.9.